Thursday, November 11, 2004

Trying to Add Updated Packages on FreeBSD 5.3 RELEASE

If you're trying to add packages shipped with FreeBSD 5.3 RELEASE, it's fairly easy, as shown in my earlier post. As long as you're running FreeBSD 5.3 RELEASE, however, pkg_add will continue to install packages shipped with that version. To avoid building new software from source using the ports tree, you might want to update an application using a new precompiled package.

At the moment, however, the FreeBSD FTP sites are not offering newer packages for FreeBSD 5.3 RELEASE. They are only providing packages shipped with 5.3 RELEASE. Here is today's contents of ftp://ftp.freebsd.org/pub/FreeBSD/ports/i386

lrwxrwxrwx 1 0 0 20 Jul 14 23:29 #cvs.cvsup-37462.728 -> packages-5.1-release
lrwxrwxrwx 1 0 0 15 Jul 14 23:29 packages -> packages-stable
lrwxrwxrwx 1 0 0 17 Jul 14 23:29 packages-4-current -> packages-4-stable
drwxrwxr-x 93 110 0 2048 Oct 16 07:18 packages-4-stable
drwxrwxr-x 92 110 0 2048 Oct 25 03:24 packages-4.10-release
drwxr-xr-x 92 110 0 2048 Oct 27 07:43 packages-5-current
drwxrwxr-x 90 110 0 2048 Oct 25 05:15 packages-5.2-release
lrwxrwxrwx 1 110 0 20 Jul 15 01:38 packages-5.2.1-release -> packages-5.2-release
drwxr-xr-x 92 110 0 2048 Nov 05 00:40 packages-5.3-release
drwxrwxr-x 92 110 0 2048 Oct 25 08:09 packages-6-current
lrwxr-xr-x 1 110 0 18 Oct 20 01:56 packages-current -> packages-6-current
lrwxrwxrwx 1 0 0 17 Jul 15 01:38 packages-stable -> packages-4-stable

The new FreeBSD 5.3 is officially a STABLE release. At the moment the packages-stable directory is a symlink to packages-4-stable. These packages are precompiled for FreeBSD 4.x. The packages-current directory is a symlink to packages-6-current. These packages are precompiled for FreeBSD 6.x.

There are packages precompiled for 5.x that are newer than those shipped with FreeBSD 5.3 RELEASE. They are in the packages-5-current directory. For example, the ftp://ftp2.freebsd.org/pub/FreeBSD/ports/i386/packages-5-current/www/ directory shows firefox-1.0.1.p_4.tbz, while the version shipped with FreeBSD 5.3 RELEASE appears in ftp://ftp2.freebsd.org/pub/FreeBSD/ports/i386/packages-5.3-release/www/ as firefox-0.9.3_1.tbz. If you want to use packages in the packages-5-current directory, set your PACKAGESITE environment variable to something like ftp://ftp2.freebsd.org/pub/FreeBSD/ports/i386/packages-5-current/All/ .

I recommend those wishing to update software installed on FreeBSD 5.3 using precompiled packages wait until they see packages-stable pointing to packages-5-stable or a similar directory. Since the precomplied packages are updated weekly, I expect to see new packages in their proper packages-5-stable directory this weekend.

1 comment:

Serg said...

The useful information